Page 23 of 23

Re: Projekt Uber Geizig 1972 VW Bus Deluxe 9 Passenger

PostPosted: May Wed 29, 2013 12:01 pm
by bigmontana
It makes the best truck.


Sent from my MB865 using Tapatalk 2

Re: Projekt Uber Geizig 1972 VW Bus Deluxe 9 Passenger

PostPosted: May Thu 30, 2013 11:04 am
by sneakyboy1
Awesome Mike! 8-)

Sent from my SCH-I535 using Tapatalk 2

Re: Projekt Uber Geizig 1972 VW Bus Deluxe 9 Passenger

PostPosted: May Thu 30, 2013 4:57 pm
by YASHA7FOLD
What the Caddy couldn't handle it. :)


Sent from my iPhone using Tapatalk

Re: Projekt Uber Geizig 1972 VW Bus Deluxe 9 Passenger

PostPosted: May Thu 30, 2013 5:01 pm
by MT-Getto
His excuse may be kids and wife, but I remember being in my dads with my mom and at least 1 brother. Not sure how that worked and if that would fly these days.......

Re: Projekt Uber Geizig 1972 VW Bus Deluxe 9 Passenger

PostPosted: May Sat 12, 2018 11:00 pm
by Mikewire
Been a while on the Bus. Getting back into it being my main project.

I've been having an issue with cyl #2 not firing, and I've chased it down to a few things. I have spark, so that's not the issue.

First was to get a visual on the valvetrain to make sure I had rockers and pushrods working properly. So here's a terrible video of me hand turning the motor over while recording the results:




Those looked fine. So, onto a compression test...

Cyl #2 came out at 115 PSI

So, that's good too! Awesome, so it's probably a fuel delivery issue. Let me check the injector...yep I found a nasty spider web thingy in one of the terminals, reconnected, and it started firing! Verified with a noid light that I am getting voltage to the injector, and have ground pulse.

However, that result was short lived. After a few starts I ended up finding the same result. So I'm expecting I have a bad injector, and I do a have a spare new one from Bus Depot ready to install tomorrow.

Also going to do a smoke test in the intake to check for leaks - it seems to have an issue with RPM hunting, so I expect I'll find something broken and/or cracked to fix.

After a bit I found the issue...well, and couple of them. Got it into European Performance where Ian and Quinn let me store the Bus in the interim before we head to TX.

Did a smoke test and found that there were small and large hard to see cracks in the S boot and one PCV hose.

Image

One was the cracked up S boot.


Image


Image

Repaired it with some super glue (cyanocrylate) and some Flex Tape (because why not...).

Also found a bad injector on my #2 clyinder, which I went ahead and replaced with a new on from Bus Depot.

Fired it up and took it for a spin firing on all 4 cylinders!

I also ordered a new S boot from Airhead parts https://airheadparts-kgpr.com/shop/bus- ... ory=Engine

When I get it, I'll do a quick review and post it up!

Re: Projekt Uber Geizig 1972 VW Bus Deluxe 9 Passenger

PostPosted: May Sun 13, 2018 10:15 pm
by YASHA7FOLD
Awesome man. Way to iron out the misfire issue.

Sent from my XT1650 using Tapatalk